Harris Dev - Timeline - Uh oh, something has gone wrong

Incident Report for Harris Arc

Resolved

Our engineers have fixed the problem. They will be doing a postmortem within the next 48 hours.
Resolved - One or more services are unavailable
Posted Jun 04, 2025 - 14:23 EDT

Identified

Don't worry, our team of engineers are investigating!
Firing - One or more services are unavailable
Posted Jun 04, 2025 - 14:08 EDT
This incident affected: Harris Dev (Timeline).